股票配资网欢迎您

稳赢剑指标请老师改成大智慧的

网上配资 2020-07-18 08:16

编写要求:

{稳赢剑{参数:N1 100 12 M1 100 20 }RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;K:=SMA(RSV,3,1);D:=SMA(K,3,1);J:=3*K-2*D;STICKLINE(REF(J,7)<0 AND J>1,10,0,10,0),COLOR00FF00;VAR1:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45))*100;VAR2:=SMA(VAR1,3,1);VAR3:=SMA(VAR2,3,1);贵:=N,COLOR00FF00;VAR4:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);VAR5:=CROSS(VAR4,10) AND VAR3VARA,VAR9,VARA,6,0),COLORRED;STICKLINE(VAR9<=VARA,VAR9,VARA,6,0),COLOR00FF00;VARB:=SUM(IF(CLOSE>REF(CLOSE,7),VOL,IF(CLOSELLV(CLOSE,VARC),1,-1);VARE:=IF(VARB>LLV(VARB,VARC),1,-1);VARF:=VARD*VARE;VAR10:=IF(VARF=-1,1,0);关注:IF(VAR10 AND CLOSE=LLV(CLOSE,20) AND VAR3OPEN,VOL,1),4); 短线逃顶:=IF(I,0,1),COLORGREEN; DRAWICON(短线逃顶,90,2);

解答:

input:n(12,1,100),m(20,1,100);

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
STICKLINE(REF(J,7)<0 AND J>1,10,0,10,0),COLOR00FF00;
VAR1:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45))*100;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
贵:=N;
VAR4:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-
LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
VAR5:=CROSS(VAR4,10) AND VAR3<N;
抄底:IF(VAR5,90,1),COLORRED;
DRAWICON(VAR5,65,1);
DRAWTEXT(VAR5,30,'抄底'),COLORYELLOW;
备钱:IF(CROSS(10,VAR4),40,1),COLORFF00FF;
DRAWICON(CROSS(10,VAR4),45,1);
DRAWTEXT(IF(CROSS(10,VAR4),1,0),20,'$备钱'),COLORWHITE;
危机线: 80,COLORRED,POINTDOT,LINETHICK2;
中间线: 50,COLORFFCCCC,POINTDOT,LINETHICK2;
安全线: 10,COLORFF00FF,POINTDOT,LINETHICK2;
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=LLV(LOW,M);
VAR8:=HHV(HIGH,M);
VAR9:=EMA((VAR6-VAR7)/(VAR8-VAR7)*100,13);
VARA:=EMA(0.667*REF(VAR9,1)+0.333*VAR9,2);
战术线: VAR9,COLORYELLOW,LINETHICK2;
战略线: EMA(0.382*REF(VAR9,2)+0.618*VAR9,12),COLORBLUE;
上一篇:在均线侧面标注价格的方法 下一篇:没有了