股票配资网欢迎您

把BS主图公式中的“B”点做个选股公式

股票配资平台 2020-07-17 09:01

编写要求:

请老师帮我把BS主图公式中的“B”点做个选股公式,谢谢!源码:a:="LTFunc6@FORLT2";s1:="LTFunc6@LT_S1"; hs:="LTFunc6@LT_HS";ls:="LTFunc6@LT_LS"; p1:="LTFunc6@LT_P1";upp:="LTFunc6@LT_UPP"; udd:="LTFunc6@LT_UDD";{hs;ls;hhs;lls;us;ds;s1;p1;p0;upp;udd};d1:=ema(abs("ddx.ddx"),60);d2:=max("ddx.ddx"/d1+7.5,7.5);d3:=min("ddx.ddx"/d1,10);fb:=if(s1=0,hs,ls);tr0:=ifs(p1=1,'明日收盘价<'+numtostrn(udd,2)+',出现S点\n','若明日收盘价>'+numtostrn(upp,2)+',出现B点\n');tr1:=ifs(s1=1,'明日收盘价<'+numtostrn(ls,2)+',短线卖出机会','若明日收盘价>'+numtostrn(hs,2)+'短线买入机会');tr2:=ifs(p1=1,ifs(cross(p1,0),'B点','持股'),ifs(cross(1,p1),'S点','持币'));tr3:=ifs(s1=0,'向下,','向上,');tr4:='3.能量级别:'+numtostrn(d3,1)+'级';bs:=''+datestr(date)+'买卖点决策系统提示\n'+'1.BS点:'+tr2+','+tr0+'2.短线:'+tr3+tr1+'\n'+tr4;drawflagtext(1,fb,bs);STICKLINE(p1=1 and c>=o and o<>0,c,o,d2,0),color5454ff;STICKLINE(p1=1 and c>=o and o<>0,c,o,7.5,0),colorblack;STICKLINE(p1=1 and c>=o and o<>0,c,c,7.5,0),color5454ff;STICKLINE(p1=1 and c>=o and o<>0,o,o,7.5,0),color5454ff;STICKLINE(p1=1 and c>=o and o<>0,o,c,7.5,1),color5454ff;STICKLINE(p1=1 and c<=o,o,c,7.5,1),color5454ff;STICKLINE(p1=1 and c<=o,l,c,0.5,1),color5454ff;STICKLINE(p1=1 and c<=o,h,o,0.5,1),color5454ff;STICKLINE((p1<>1 or barscount(c)<3) and c>=o,c,o,7.5,1),colorffff54;STICKLINE((p1<>1 or barscount(c)<3) and c>=o,c,h,0.5,1),colorffff54;STICKLINE((p1<>1 or barscount(c)<3) and c>=o,l,o,0.5,1),colorffff54;drawbmp(p1=1 and ref(p1,1)=0,l,'buy1.bmp'),align1,valign0;drawbmp(p1=0 and ref(p1,1)=1,h,'sell1.bmp'),align1,valign2;drawbmp(s1=1 and ref(s1,1)=0 and (p1+ref(p1,1))<>1,l,'bs.bmp'),align1,valign0;drawbmp(s1=0 and ref(s1,1)=1 and (p1+ref(p1,1))<>1,h,'ss.bmp'),align1,valign2;{均线}MA5:MA(CLOSE,5);MA13:MA(CLOSE,13);MA21:MA(CLOSE,21);MA34:MA(CLOSE,34);MA62:MA(CLOSE,62);MA120:MA(CLOSE,120);

解答:


p1:="LTFunc6@LT_P1";
p1=1 and ref(p1,1)=0;
上一篇:大智慧版的龙虎分时 下一篇:没有了